Lotus Elan

Dellorto Carburator

PostPost by: pete.chiswell » Thu Aug 19, 2021 1:26 pm

Hi I have +2 130s which came mainly in boxes. I have assembled the pair of Dellorto carburettors, no bits left but I cannot see how to connect the throttle cable to the carb. I have a barrel nipple that fits the inner cable and throttle linkage but no way of attaching the outer cable. I have no bracket nor can I see any screw holes. Can anyone send me a picture of how its fitted or part numbers. I attach a photo of what I have.
Attachments
IMG_1301.jpg and
pete.chiswell
New-tral
 
Posts: 6
Joined: 15 Aug 2020
Location: Northampton

PostPost by: George S L » Thu Aug 19, 2021 2:23 pm

004.jpg and
003.jpg and
Hi Pete the bracket for the cable is attached to the air box hope you can see it from the photos
George
Elan+2
Mk2 Mx5
George S L
Second Gear
Second Gear
 
Posts: 56
Joined: 28 Feb 2019
Location: yorkshire

PostPost by: ericbushby » Thu Aug 19, 2021 2:53 pm

George, pardon me for adding to your post.

Pete, It is an odd arrangement.
The inner cable is fixed to the air box bracket with a nipple as you would see on a pushbike and in George`s photo but does not move.
The cable arrives at the carbs from above and the outer fits into a barrel nipple on the shaft lever.
It is the outer cable which goes down and up to open and close the throttle. It was an unfamiliar method to me and not obvious at first, but it works well enough.
Mine has Weber carbs but I think they use the same arrangement as yours.
Hope this helps
Eric in Burnley
S3SE DHC
ericbushby
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1063
Joined: 13 Jun 2011
Location: east lancashire

PostPost by: pete.chiswell » Thu Aug 19, 2021 6:57 pm

Thanks guys I need to search my boxes for the air box. I was totally baffled
pete.chiswell
New-tral
 
Posts: 6
Joined: 15 Aug 2020
Location: Northampton

PostPost by: RedBarnMan » Sat Sep 04, 2021 7:55 pm

When you do put it all together, make sure the accelerator pedal does fully open the butterflies on the carburettors. Mine used to be a real so and so to start then I discovered the accelerator pedal was not opening the butterflies fully and as such was not operating the accelerator pump which supplies a richer mixture when starting and accelerating hard. (I don't use the choke control, just 3 pumps on the accelerator pump by flooring the accelerator pedal 3 times before a cold start).
RedBarnMan
First Gear
First Gear
 
Posts: 20
Joined: 23 Aug 2013
Location: Woodbridge, Suffolk

Total Online:

Users browsing this forum: No registered users and 3 guests