Lotus Elan

Need some advice/opinions

PostPost by: Robbie693 » Fri Jan 26, 2007 10:55 am

Well I've checked the serial number and the one I need (LR18221) is not on the box. There is another number which is also on the tag that is attached to the air valve pipe (4258 221). So I rang Delphi and they checked this number which turns out to be correct. Hurrah!

Don't know why they have two different numbering systems but is anyone else is confused this is the way to check (assuming the tag is still attached).

Incidentally, the installation guide I got off the net says that the vacuum hose should be installed with a loop dropping down below the level of the servo and inlet manifold, like a 'U' trap to prevent petrol vapour getting into the servo. I've never seen one installed like this, anyone done it?
Attachments
Servo-_install.jpg and
User avatar
Robbie693
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1641
Joined: 08 Oct 2003
Location: UK

PostPost by: miked » Fri Jan 26, 2007 3:56 pm

I have not followed this thread from the start but picked up on your question.

I did this with the very same unit on my S4. I picked up an additional valve from Stoneliegh of another Lotus for ?1.50.

I did exatly what is said as I had a servo fail. ?180 and 18 months after the refurb'. Also brake fluid in the inlet manifold burning away my master cylinder level. Petrol got at the Diaphram. Hence the two non return valves and the loop and "Tee" off upwards. It should not happen again. I left quite loop in the nose.

Mike
User avatar
miked
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1238
Joined: 29 Sep 2003
Location: West Lancashire

PostPost by: Robbie693 » Fri Jan 26, 2007 5:07 pm

Thanks Mike.

I got a price for the non-return valve - ?31.89 which was a bit of a shock!

Can I use any (cheaper) valve or are they rated for certain applications?

Also, thinking about it, isn't the non-return valve in the servo enough?
User avatar
Robbie693
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1641
Joined: 08 Oct 2003
Location: UK

PostPost by: miked » Fri Jan 26, 2007 10:36 pm

Robbie

I picked up a new old stock servo valve from C Neil on one of their clear outs. I cant recall what it was off but it was for a Lotus servo system. No info' on it now. They will have a rating but to be honest I did not check. Bit naughty, but I figured if it failed I would still have the other one and it would more likely fail to seat than anything else. The servo does have one on but the instructions say that on high performance engines you should fit a second one. I fitted this and it works fine.


Just for reference I found that servo at a Moggie 1000 site for ?112 before VAT. (about a year ago) Have seen the same one at ?240 in the Burton cat'.

Why dont you contact the brake servo manufacturer.

Mike
User avatar
miked
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1238
Joined: 29 Sep 2003
Location: West Lancashire

PostPost by: Robbie693 » Sat Jan 27, 2007 12:43 pm

Thanks again Mike,

I was talking to Paul Matty/s and they said that some Plus2's were fitted with a valve in the metal portion of the vacuum pipe. I'll have to do some investigation into this.

In the meantime I'll fit the servo anyway - I imagine the just valve in the servo will be ok for a bit.

Cheers

Robbie
User avatar
Robbie693
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1641
Joined: 08 Oct 2003
Location: UK

PostPost by: berni29 » Mon Jan 29, 2007 4:31 am

Hi There

The chap at Norton servos is still in business for sure. I spoke to him last week.

Berni
Zetec+ 2 under const, also 130S. And another 130S for complete restoration. Previously Racing green +2s with green tints. Yellow +2 and a couple of others, all missed. Great to be back 04/11/2021 although its all starting to get a bit out of control.
User avatar
berni29
Fourth Gear
Fourth Gear
 
Posts: 817
Joined: 10 Mar 2004
Location: Beckenham Kent
Previous

Total Online:

Users browsing this forum: ken_apple, khamai, pharriso and 12 guests