Lotus Elan

I now have the Elan +2 home

PostPost by: gsminors » Sun Feb 05, 2006 11:24 pm

I just picked the 69 Elan +2 only a short drive home but what a ride. Totaly impressed on how well the engine goes very free revving and smooth. I am now looking forward to getting it all sorted out and ready for the summer. I will post more later after I get the car down to my shop for the work. I will also post details on my web site later as well.
Geoff Minors
1969 Lotus Elan +2
1972 MGB (being restored)
1981 Fiat X19
1973 Norton 850 Commando
User avatar
gsminors
Second Gear
Second Gear
 
Posts: 53
Joined: 25 Jan 2006
Location: Okotoks, Alberta

PostPost by: john.p.clegg » Mon Feb 06, 2006 7:08 am

Ready for the summer (which year?)

John :wink:
User avatar
john.p.clegg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 5684
Joined: 21 Sep 2003
Location: Manchester

PostPost by: masermartin » Tue Feb 14, 2006 7:18 pm

Yeah, it all starts innocently enough :)

I am still sorting out my 1970 MGB and I thought I would be driving it already. Maybe 2 more weeks ;) We'll see.

Congrats by the way, I hope to one day own an Elan +2 as well.
masermartin
First Gear
First Gear
 
Posts: 22
Joined: 02 Aug 2005
Location: Atlanta, GA

PostPost by: gsminors » Tue Feb 14, 2006 8:13 pm

Some of the things I need to do are:
Suspension is leaning to one side by 1" I have orderd new rear springs and I have new Koni strut inserts to go when I replace the springs.
Some minors interior tidying up.
Temp gauge is reading wrong (very low)
Speedometer is jumping around
replace the wood boards in the boot
Re spray
I have K & N air filters on order
Going back to the rear suspension. It will oversteer on a bumpy raod and on a straight on a bumpy road it will try and rear steer. Any ideas?
The engine is in fairly good tune but it will run on after the ignition is turned off, might try some hotter plugs and check the timing.
Any help will be appreciated
Geoff Minors
1969 Lotus Elan +2
1972 MGB (being restored)
1981 Fiat X19
1973 Norton 850 Commando
User avatar
gsminors
Second Gear
Second Gear
 
Posts: 53
Joined: 25 Jan 2006
Location: Okotoks, Alberta

PostPost by: 1964 S1 » Wed Feb 15, 2006 2:54 am

Hello, if the temp gauge is not functioning properly, are you sure the car's not running hot? What octane fuel is in it? Both can affect run after.
1964 S1
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1496
Joined: 15 Sep 2003
Location: Hamilton County, Ohio

Total Online:

Users browsing this forum: No registered users and 8 guests