Lotus Elan

Hello

PostPost by: chrisstarr396 » Sat Dec 25, 2021 8:47 pm

Hello,
First wishing everyone a very Merry Christmas and happy holidays. Just came into possession of my dads 1969 Elan +2, British racing green. I enjoyed working on the car when I was a kid and look forward to jumping back into it. It hasn't run since early 90's due to some carb issues and been garaged the entire time. Is there a check list for trying to get this thing running? Before he passed he said the engine was frozen. Just wanted to see if there is an order of parts to be checked/replaced before trying to start the vehicle? Love the website and already have gone down so many rabbit holes.

Chris
69 Elan +2
chrisstarr396
New-tral
 
Posts: 7
Joined: 25 Dec 2021
Location: California

PostPost by: berni29 » Sun Dec 26, 2021 12:01 am

Hi

Welcome on board. Sorry to hear of your dad's passing, but pleased the +2 is staying in the family. My last +2 before my recently acquired one was in BRG with a black interior and a green tinted screen. What a looker!

Do you have any pictures of the car?



All the best

Berni
Attachments
green.jpeg and
Zetec+ 2 under const, also 130S. And another 130S for complete restoration. Previously Racing green +2s with green tints. Yellow +2 and a couple of others, all missed. Great to be back 04/11/2021 although its all starting to get a bit out of control.
User avatar
berni29
Fourth Gear
Fourth Gear
 
Posts: 796
Joined: 10 Mar 2004
Location: Beckenham Kent

PostPost by: chrisstarr396 » Sun Dec 26, 2021 12:10 am

That car looks amazing. Im heading up next week to uncover it and take a look. Ill get some pics.
chrisstarr396
New-tral
 
Posts: 7
Joined: 25 Dec 2021
Location: California

PostPost by: Donels » Sun Dec 26, 2021 7:31 pm

First thing would be to check if the engine is 'frozen'. I would remove the plugs and put a good squirt of oil in each cylinder and leave for a few minutes. Then try and rotate the engine by hand either via the crank pulley or moving the car whilst in top gear.
If still frozen then put a slug of diesel in each cylinder and leave for a few days. Repeat hand cranking.

If it frees up then your into normal recommissioning with oil and fluid changes etc, before cranking with the plugs out to get oil rotating through the engine. Probably before that though you need to drain the fuel tank and flush the fuel lines with fresh fuel, checking for any leaks from perished hoses, etc. if all is ok then try a start.

If it doesn’t free then your into an engine strip.

Good luck.
Elan +2
Elise mk 1
Donels
Fourth Gear
Fourth Gear
 
Posts: 698
Joined: 10 Sep 2016
Location: Tamworth

PostPost by: chrisstarr396 » Sun Dec 26, 2021 9:41 pm

Very much appreciated.
chrisstarr396
New-tral
 
Posts: 7
Joined: 25 Dec 2021
Location: California

PostPost by: mbell » Sun Dec 26, 2021 10:02 pm

Before trying to crank it with the starter pump some oil in to the oil pressure gauge take off in the engine (by the pool pump). This gets oil to all the bearings before putting a significant load on them.
'73 +2 130/5 RHD, now on the road and very slowly rolling though a "restoration"
mbell
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 2717
Joined: 07 Jun 2013
Location: Austin, TX (UK Ex-pat)

PostPost by: The Veg » Sun Jan 02, 2022 12:11 am

Welcome Chris! Glad to hear of another Plus 2 coming back to life, especially here in USA where they are so rare!
1970 Elan Plus 2 (not S) 50/2036
2012 BMW R1200GS
"It just wouldn't be a complete day if I didn't forget something!" -Me
User avatar
The Veg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 2350
Joined: 16 Nov 2015
Location: Atlanta 'burbs (southeast USA)

Total Online:

Users browsing this forum: No registered users and 3 guests