Lotus Elan

Any probs with Misab plates on Dellortos?

PostPost by: M.J.S » Fri Aug 08, 2008 8:49 am

I have just refitted my Dellortos with brand new mounting kits from Dellorto UK, using genuine Misab plates instead of the old plastic spacers and Cosworth mounts.

Since then my mixtures have gone to cock, far too rich and I am having trouble getting them weak enough.

Anybody else had trouble with Misab plates? I always thought they would be better than the old style spacers and O rings.

Mark.
User avatar
M.J.S
Second Gear
Second Gear
 
Posts: 170
Joined: 21 May 2008
Location: Lancashire, UK.

PostPost by: ppnelan » Fri Aug 08, 2008 8:57 am

:idea: If they're now 'far too rich', perhaps the new plates have sealed up air leaks that may have been present before :?:
Or are the chokes stuck on :?:
Just a thought... :)

:arrow: Matthew
ppnelan
Fourth Gear
Fourth Gear
 
Posts: 734
Joined: 16 Sep 2003
Location: Norfolk, UK

PostPost by: M.J.S » Fri Aug 08, 2008 10:40 am

Carbs are brand new and the chokes are certainly not stuck. On cyl 2 and 3 the mixture screws are all the way in and the plugs are coked up to hell. All 4 plugs were a nice light brown before I fitted the new mounts. :x

Mark.
User avatar
M.J.S
Second Gear
Second Gear
 
Posts: 170
Joined: 21 May 2008
Location: Lancashire, UK.

PostPost by: ppnelan » Fri Aug 08, 2008 11:27 am

Are the float heights correct?
Could the needle valves be sticking (dirt in fuel)?
Are the jets correct /standard?
Just a few ideas to get you thinking... :wink:

:arrow: Matthew
ppnelan
Fourth Gear
Fourth Gear
 
Posts: 734
Joined: 16 Sep 2003
Location: Norfolk, UK

Total Online:

Users browsing this forum: No registered users and 9 guests