Lotus Elan

Weber Carbs.

PostPost by: smo17003 » Mon May 15, 2006 7:30 pm

Looking over my new Elan project I notice that the Webers are neither 18's or 31's but are both marked 126. Is this something I should worry about or not?

Mike
smo17003
Second Gear
Second Gear
 
Posts: 65
Joined: 11 May 2006
Location: Oxford, England

PostPost by: ElliottN » Tue May 16, 2006 1:41 pm

Mike,

Can you check again. Are you saying the carbs are identified "Tipo 40 DCOE 126"?

Elliott.
Elliott - 70 S4 dhc
User avatar
ElliottN
Second Gear
Second Gear
 
Posts: 189
Joined: 19 Apr 2004
Location: Sydney, Australia

PostPost by: smo17003 » Thu May 18, 2006 5:32 pm

Hello Elliott,

Yes, they are Tipo 40 DCOE 126A.

Mike
smo17003
Second Gear
Second Gear
 
Posts: 65
Joined: 11 May 2006
Location: Oxford, England

PostPost by: ElliottN » Sat May 20, 2006 9:43 am

Hmmmm...

I'm hardly a Weber expert but I haven't come across references to 126A's before but basically a DCOE40 is a DCOE40 - the different types generally vary the accelerator pump and the progression circuits and were intended to suit the characteristics of different car/engine combinations. My Elan has DCOE 40 Type 2's and I have no issues whatsoever. I don't know when/how it got them - both the previous 2 owners swear they were on it during their ownerships which accounts for nearly 30 years!

I wouldn't get alarmed right now. Keep going and wait until you're up and running to see if you actually hit any issues.

Sorry I can't be more helpful.
Elliott - 70 S4 dhc
User avatar
ElliottN
Second Gear
Second Gear
 
Posts: 189
Joined: 19 Apr 2004
Location: Sydney, Australia

Total Online:

Users browsing this forum: No registered users and 5 guests