Lotus Elan

Oil pump - original colour

PostPost by: 2cams70 » Fri Jul 17, 2020 9:27 am

Hi Guys,
One for the anoraks - was the oil pump on the Lotus Twin cam engine originally painted the same colour as the engine block (i.e Ferguson Grey) or was it left unpainted? I know on crossflow engines the pump was the same colour as the block (i.e black) but the assembly sequence may have been different on the LTC and the pump bolted to the block after short block assembly in which case it would most likely would have been left unpainted.

I know it's very unlikely anyone has an original Twin Cam that has never been apart at some stage but here's hoping!
1970 Ford Escort Twin Cam
1972 Ford Escort GT1600 Twin Cam
1980 Ford Escort 2.0 Ghia
Peugeot 505 GTI Wagons (5spdx1) (Autox1)
2015 Honda City 5spd.
2cams70
Fourth Gear
Fourth Gear
 
Posts: 938
Joined: 10 Jun 2015
Location: Australia

PostPost by: promotor » Fri Jul 17, 2020 11:17 am

Standard bare metal finish.
User avatar
promotor
Fourth Gear
Fourth Gear
 
Posts: 528
Joined: 16 Mar 2012
Location: Derbyshire, U.K.

PostPost by: Mazzini » Fri Jul 17, 2020 11:17 am

The engine on my S3 was in the original paint, it still had the chassis number hand written across the front (for ease of identification when being fitted or assigned to a kit). The oil pump was unpainted, but the black metal canister that the filter sits in still had a Ford stencil on the side.
User avatar
Mazzini
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1895
Joined: 11 Dec 2010
Location: NE UK

PostPost by: TBG » Fri Jul 17, 2020 12:40 pm

Yup - bare metal.
TBG
Second Gear
Second Gear
 
Posts: 88
Joined: 21 Apr 2020
Location: England

PostPost by: 2cams70 » Fri Jul 17, 2020 1:42 pm

Ok great. Thanks guys.
1970 Ford Escort Twin Cam
1972 Ford Escort GT1600 Twin Cam
1980 Ford Escort 2.0 Ghia
Peugeot 505 GTI Wagons (5spdx1) (Autox1)
2015 Honda City 5spd.
2cams70
Fourth Gear
Fourth Gear
 
Posts: 938
Joined: 10 Jun 2015
Location: Australia

PostPost by: rgh0 » Sat Jul 18, 2020 1:09 am

Mazzini wrote:The engine on my S3 was in the original paint, it still had the chassis number hand written across the front (for ease of identification when being fitted or assigned to a kit). The oil pump was unpainted, but the black metal canister that the filter sits in still had a Ford stencil on the side.



Yes my S4 was the same except for the hand written engine number in 1974 when I first got it with the original engine.....many engines ago

cheers
Rohan
User avatar
rgh0
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 7512
Joined: 22 Sep 2003
Location: Melbourne, Australia

Total Online:

Users browsing this forum: Dale Harvey and 10 guests