Lotus Elan

Dash Fan switch problem, rocker type

PostPost by: sprintsoft » Mon Sep 21, 2020 11:19 am

Has anyone got a spare switch I could buy?

The high speed position on the Elan fan switch started not to work, I removed the switch cleaned up the internal contacts, reassembled, tested it and found a bad connection where the spade connector Is rivetted, see photo... It’s slightly loose, enough to stop the fan running.

E5ACBADE-90EF-4710-9846-20F951D3B893.jpeg and


I can’t see how to reliably tighten or replace the rivet... any ideas?

FYI - the fan switch is exactly the same on the 130/5 dash.

Thanks
Iain
72 Sprint - 0363E
74 S130/5 - 1931L
sprintsoft
Second Gear
Second Gear
 
Posts: 190
Joined: 18 Mar 2019
Location: Swansea, Wales, UK

PostPost by: nmauduit » Mon Sep 21, 2020 12:25 pm

is it an original switch or a repro? I believe the original ones can be dismantled (probably not too many times), which would enable to inspect the inside for carbon deposit (quite a bit of current in the fan), and possibly tighten the rivet thanks to both side access.

other than that, soldering (like for electronics) ? watching out for plastic damage, I would use a large soldering to have enough heat capacity and heat quick and out, before too much heat is transmitted to the plastic. I see some oxidation (greenish color), application of reducing contact grease may be of help, too...
S4SE 36/8198
User avatar
nmauduit
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1553
Joined: 02 Sep 2013
Location: France

PostPost by: sprintsoft » Mon Sep 21, 2020 1:30 pm

Thanks Nic,

It's an original, I guess it has had the wiring detached a few times and so the pulling and pushing the wiring on and off would loosen it. I did fully dismantle and clean up the internal contacts springs etc... then found the loose spade connector later.

I suspect the solder will not hold if the contact has movement, so I may try dismantling again and squeeze the rivet up - but it doesnt look too strong to me.

Iain
72 Sprint - 0363E
74 S130/5 - 1931L
sprintsoft
Second Gear
Second Gear
 
Posts: 190
Joined: 18 Mar 2019
Location: Swansea, Wales, UK

PostPost by: john.p.clegg » Mon Sep 21, 2020 2:02 pm

Looks like that rivet has ben peened over more than once..

John ;-)
User avatar
john.p.clegg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 5709
Joined: 21 Sep 2003
Location: Manchester

PostPost by: lotusfan » Mon Sep 21, 2020 2:08 pm

Maybe drill out the rivet and replace with a tiny screw and nut, 6 BA or 8 BA? or the metric equivalent.
Mike
72 Sprint DHC
User avatar
lotusfan
Third Gear
Third Gear
 
Posts: 309
Joined: 15 Sep 2003
Location: S Bucks, UK

PostPost by: sprintsoft » Mon Sep 21, 2020 6:25 pm

Johns right, comparing to another switch the rivet has been squeezed up before so that’s not an option.

For interest I ran the fan full speed direct from the battery at 12.6v and it’s pulling 5A = 63 watts.

(Slow speed pulls 3.5A)

If I can get the switch sorted should I put a relay on the fast speed? otherwise the switch runs hot.
72 Sprint - 0363E
74 S130/5 - 1931L
sprintsoft
Second Gear
Second Gear
 
Posts: 190
Joined: 18 Mar 2019
Location: Swansea, Wales, UK

PostPost by: sprintsoft » Mon Sep 21, 2020 6:26 pm

lotusfan, thanks I hadn’t thought of that one, maybe a last resort...
72 Sprint - 0363E
74 S130/5 - 1931L
sprintsoft
Second Gear
Second Gear
 
Posts: 190
Joined: 18 Mar 2019
Location: Swansea, Wales, UK

Total Online:

Users browsing this forum: No registered users and 9 guests