Lotus Elan

Smith fuel gauge goes by rev

PostPost by: umbyfer » Wed Mar 07, 2018 8:39 pm

hello,

my Smiths fuel instruments on elan sprint, goes following the rev engine. It means that at minimum rev the instrument works well indicating the correct level of fuel, as when the engine is off only with the key on ON position). But at 1500 rev or more, the fuel gauge moves slow up to full. Stopping the car at minimum rev the indicator goes down to the correct level of fuel.

I changed the fuel sender unit by a new one; i replaced the black wiring from sender unit to ground.
Why it happens? where is the problem? how to repair it?

thank you to all!!
Umberto Ferrari
Modena - Italy
Elan Sprint 7108000193K
Elite SII #1319
umbyfer
Second Gear
Second Gear
 
Posts: 188
Joined: 03 Apr 2004
Location: Modena - Italy

PostPost by: webbslinger » Wed Mar 07, 2018 9:55 pm

How about checking the voltage stabilizer on the back of the speedometer.
webbslinger
Second Gear
Second Gear
 
Posts: 145
Joined: 23 Jun 2012
Location: Friday Harbor, WA USA

PostPost by: Chrispy » Fri Mar 09, 2018 9:50 pm

Yep, sounds like voltage stabaliser. Or even the voltage regulator out of the generator/alternator. Nothing else strange going on?
Chris
Elan +2 #0245
Exige S2 Supercharged
Chrispy
Third Gear
Third Gear
 
Posts: 304
Joined: 29 Oct 2017
Location: Brisbane, Australia

PostPost by: umbyfer » Sat Mar 10, 2018 7:52 am

Hello, thank you. For some reason there are two identical topics with the same title; the discussion is going on on the second one. Sorry for that.
Umberto Ferrari
Modena - Italy
Elan Sprint 7108000193K
Elite SII #1319
umbyfer
Second Gear
Second Gear
 
Posts: 188
Joined: 03 Apr 2004
Location: Modena - Italy

Total Online:

Users browsing this forum: elanfan1 and 15 guests