Lotus Elan

Otter switch connector

PostPost by: kstrutt11 » Wed Aug 26, 2009 8:43 pm

The cooling fan has packed up on my +2S130, I've purchased a modern one to replace it and plan to re-wire with a relay as it is more powerfull, the only problem I have is that the connector into the otter switch is missing (currently 2 dodgey crimp connectors are used to wire it in) has anyone found somewhere to buy the proper connector (I don't even know what it looks like!)

kevin
kstrutt11
Third Gear
Third Gear
 
Posts: 319
Joined: 27 Jun 2007

PostPost by: Frank Howard » Thu Aug 27, 2009 1:23 am

Kevin,

I tried to buy the "proper" connector. Apparently, the crimp connectors are the proper connectors!
Frank Howard
'71 S4 SE
Minnesota
Frank Howard
Fourth Gear
Fourth Gear
 
Posts: 994
Joined: 30 Mar 2004

PostPost by: tdafforn » Mon Aug 31, 2009 12:42 pm

Apparently you can find the proper clip on an early austin metro
Cheers
tim
1972 +2S130
User avatar
tdafforn
Fourth Gear
Fourth Gear
 
Posts: 867
Joined: 12 Sep 2003
Location: Kenilworth Warwks.

PostPost by: kstrutt11 » Tue Sep 01, 2009 11:54 am

I was sure I had seen a connector used somewhere on similar switches, trouble is most early 80's / late 70's leyland stuff is now rarer than the +2 !
In the end I have used crip on connectors and covered the horrible red plastic with black shrink wrap.
kstrutt11
Third Gear
Third Gear
 
Posts: 319
Joined: 27 Jun 2007

PostPost by: tdafforn » Tue Sep 01, 2009 1:55 pm

just checked, also same switch on a maestro
Cheers
tim
1972 +2S130
User avatar
tdafforn
Fourth Gear
Fourth Gear
 
Posts: 867
Joined: 12 Sep 2003
Location: Kenilworth Warwks.

Total Online:

Users browsing this forum: No registered users and 14 guests