Lotus Elan

ignition timing

PostPost by: triumphelan » Mon Jan 16, 2006 7:11 am

I have a S4 with webers .What should I set the ign timing at ? I have seen the setting in the manual but I am using unleaded fuel .I have read the archives so I may set it at manual setting and check for pinling .Any recomendations
Regards John
Regards John 1969S4DHC
triumphelan
Third Gear
Third Gear
 
Posts: 297
Joined: 04 Jul 2005
Location: UK North London HA61PY

PostPost by: Dag-Henning » Mon Jan 16, 2006 8:09 am

Lead or no lead does not affect the timing. ( - octane figure does though... ) Believe the bible says 12 deg. static for a "Weber SE " .

Dag
Elan S1 -64/ Elan race-replica 26R / Works Escort TwinCam -69/ Brabham BT41 Holbay
User avatar
Dag-Henning
Third Gear
Third Gear
 
Posts: 461
Joined: 30 Sep 2004
Location: Oslo, Norway

PostPost by: rgh0 » Mon Jan 16, 2006 8:15 am

Try 25 to 27 degrees maximum total advance as a starting point and then play up and down from there. A standard weber twin cam generally does not need more than this and depending on fuel and compression ratio may need a little less.

Rohan
User avatar
rgh0
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 7570
Joined: 22 Sep 2003
Location: Melbourne, Australia

PostPost by: ianf » Mon Jan 16, 2006 2:02 pm

John,

I run my sprint on shell optimax (98octane rather than 97 usual "super unleaded"??) plus millers VSP and set the timing at 10-12 btdc and so far no pinking or probs.

Ian
ianf
Second Gear
Second Gear
 
Posts: 174
Joined: 06 Jan 2006
Location: surrey uk

Total Online:

Users browsing this forum: No registered users and 6 guests