Lotus Elan

Speedo gear and fever

PostPost by: Tahoe » Sun May 15, 2011 8:56 pm

Okay,

I've been sick for a few days and I think my fever is affecting my sanity.

I can't get my speedo gear to seat properly. Since my old gear was broken and so was my angle drive I finaly got around to replacing them.

When installed in the transmission should it look like this?
Image

I know the bushing is very chewed up (I didn't do it) but it will seal. If it looks like this there is no way to seal against the o-ring.

Or like this?

Image

This way it will seal the 0-ring against the angle drive, but I can't get it to go in any further.

I'm giving up for today since I don't feel good, but all help is appreciated.
Tahoe
Fourth Gear
Fourth Gear
 
Posts: 687
Joined: 19 Sep 2010

PostPost by: Tahoe » Sun May 15, 2011 10:46 pm

Guys I think I know the problem. I seem to be missing an adapter between the aluminum bearing (bushing) and angle drive. Since everything was all broken etc. I believe the previous owner or owners cobbled up a away for the angle drive to seal. It looks like they cut off part of the angle drive threaded part so the angle drive would seal directly against the o-ring. I was wondering why my new angle drive looked different, but since I didn't know any better and my manual wasn't very clear I thought that was the way it was.

I know this may not make sense without pictures, but can someone confirm my suspicions?

If this is the case I know need to source this adapter between the angle drive and the aluminum bearing (bushing)
Tahoe
Fourth Gear
Fourth Gear
 
Posts: 687
Joined: 19 Sep 2010

PostPost by: garyeanderson » Mon May 16, 2011 11:37 am

y
Attachments
speedo adapter parts.JPG and
speedo adapter1.JPG and
speedo adapter.JPG and
User avatar
garyeanderson
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 3128
Joined: 12 Sep 2003
Location: Massachusetts, U.S.A.

PostPost by: Tahoe » Mon May 16, 2011 4:01 pm

Thanks for the pictures. It's very clear what I'm missing.
Tahoe
Fourth Gear
Fourth Gear
 
Posts: 687
Joined: 19 Sep 2010

PostPost by: Tahoe » Mon May 16, 2011 5:57 pm

I was able to get one from RD this morning. He had one NOS in stock! Looks like I'm back in business again!
Tahoe
Fourth Gear
Fourth Gear
 
Posts: 687
Joined: 19 Sep 2010

Total Online:

Users browsing this forum: No registered users and 3 guests