Lotus Elan

40 DCOE throttle linkages

PostPost by: mbell » Fri Jan 08, 2016 7:28 pm

simonknee wrote:They always felt sticky no matter what you lube them with. That was until I made one myself with Shimano teflon brake cable. It feels wonderful.


Thanks, that an interesting/good idea. Cable on my car doesn't stick but feels very rough so I may have to try this mod.
'73 +2 130/5 RHD, now on the road and very slowly rolling though a "restoration"
mbell
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1667
Joined: 07 Jun 2013
Location: Austin, TX (UK Ex-pat)

PostPost by: simonknee » Sat Jan 09, 2016 2:59 pm

You won't regret it. Be careful to finish the ends of the cable outer with some kind of ferrule or they will fray and collapse (no really, didn't happen to me, honest..) If you have an existing standard cable it is worth re-using the adjuster section. I did this myself because of the rough feel making it difficult to accelerate smoothly. An unexpected benefit was a much more reliable return to idle.
Simon
'67 S3 FHC 36/7002
'69 +2 50/1370 (stolen '00)
User avatar
simonknee
Fourth Gear
Fourth Gear
 
Posts: 916
Joined: 18 Sep 2003
Location: London

PostPost by: el-saturn » Sat Jan 09, 2016 4:32 pm

it's either a brocken mount, or both sides mixed up or the wrong ones. the regular screw-heads are 5mm high: use another type which'll give u a couple of additional mi clearancel! good luck sandy
el-saturn
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1420
Joined: 27 Jun 2012
Location: switzerland
Previous

Total Online:

Users browsing this forum: No registered users and 7 guests