Lotus Elan

fuel leak

PostPost by: chrishewett » Sat Jul 16, 2005 2:11 pm

I took my +2 for a short spin today and when I came back I noticed a few drops of petrol under the car. When I investigated I think it is coming from between the carbs ( weber) and manifold. The drips stopped after a few minutes. I dont think it is leaking when running.
I am sure I saw mention of this problem some time ago on this forum but I cant find the thread.
Any ideas?
Chris
chrishewett
Third Gear
Third Gear
 
Posts: 472
Joined: 06 Oct 2003
Location: Lincolnshire

PostPost by: Hamish Coutts » Sat Jul 16, 2005 8:52 pm

Chris,

Do you have a mechanical fuel pump? If so, have a look at the bottom of the pump. There is a small drain hole there. Just reach under the carbs and feel the bottom of the pump. Smell petrol? Looks like you have a fuel leak in the rubber pump diaphram. If you have watch it! The pump may be leaking directly into the engine and diluting the oil. Recommend you fix it fast - and change the oil.

Electric pump? Is the pressure too high at the carbs?

Also check float levels carb/gaskets.

A starting point - I hope.

E-mail me if you need to discuss this further.

Regards,

Hamish.
"One day I'll finish the restoration - honest, darling, just a few more years....."
User avatar
Hamish Coutts
Fourth Gear
Fourth Gear
 
Posts: 517
Joined: 29 Jun 2004
Location: Scotland.

PostPost by: chrishewett » Sun Jul 17, 2005 11:47 am

I just checked the float levels and I think they were about 1.5mm to high.
Reset and short test drive and all seems to be well.
Only problem now is that it doesnt seem to want to rev smoothly between 3,500 and 5,000 ( it was doing this before). In neutral it revs up smoothly but not when driving.
Any ideas?
Chris
chrishewett
Third Gear
Third Gear
 
Posts: 472
Joined: 06 Oct 2003
Location: Lincolnshire

Total Online:

Users browsing this forum: No registered users and 4 guests