Lotus Elan

Tachometers aka Rev Counters

PostPost by: ardee_selby » Sun Oct 02, 2011 6:35 pm

General Info...may be of interest, if not for Elans, perhaps for others in your stable(s) :wink:

Enjoy...

Tacho1.jpg and

Tacho2.jpg and
ardee_selby
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 2255
Joined: 30 Sep 2003
Location: Outta Here

PostPost by: UAB807F » Mon Oct 03, 2011 5:17 am

Good post, there's more variety in the smith's tachos than I'd have thought.

(and pictures always work better for me than descriptions ! )
User avatar
UAB807F
Fourth Gear
Fourth Gear
 
Posts: 645
Joined: 20 Dec 2010
Location: Lincolnshire

PostPost by: MickG » Tue Oct 04, 2011 11:05 am

Not sure which thread to post this under as there are two running along the same lines. I have been experiencing problems with my Smiths RVI tach on my 71 Sprint. When I purchased the car it had electronic ignition installed and the tach needle was bouncing all over the place, a common problem. I removed the luminition ignition system and reinstalled a set of points. This cured the problem. I have since replaced the wiring loom and wired according to the wiring diagram. All works OK but the needle is still not quite as stable as it should be and tends to bounce from time to time. The diagrams posted by ardee_selby are very helpful but do conflict with the Lotus wiring diagram. The Lotus diagram shows the feed from the ignition switch passing through the tach sensing coil via the anti theft switch on to the coil. the other side of the coil then goes to the distributor. The two diagrams at the top of page 1 show two Smiths RVI tach's. The one I have fitted is the first one but the Lotus wiring dia shows it connected as per the second one.
Which is correct as I am now pretty confused :?
MickG
Third Gear
Third Gear
 
Posts: 314
Joined: 14 Jan 2011
Location: Essex,UK

Total Online:

Users browsing this forum: Andrewelan and 12 guests