Lotus Elan

Electric washer pump?

PostPost by: patrics » Thu Nov 25, 2010 6:34 pm

Neil,

I might have one - just been to look but couldn't find it will try again over weekend - I need to move some stuff

Regards
Steve
patrics
Fourth Gear
Fourth Gear
 
Posts: 549
Joined: 21 Sep 2003

PostPost by: smedith » Sat Nov 27, 2010 5:44 pm

Hi All

I would just like to say a thank you to a kind member that sent me a bottle in the post.

Sadly it was a Heller unit not the Tudor unit Im looking for, as seen in the pictures.

If any one has a Tudor unit in any condition, broken or damaged, or can help me find one I would really appreciate it.

Best regards to all

Neil
smedith
New-tral
 
Posts: 8
Joined: 10 Dec 2008

PostPost by: john.p.clegg » Sat Apr 16, 2011 8:37 am

Yes to all three,especially if it's cold enough where you are to freeze the water (no antifreeze?)...

John :wink:
User avatar
john.p.clegg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 5708
Joined: 21 Sep 2003
Location: Manchester

PostPost by: GrUmPyBoDgEr » Sat Apr 16, 2011 9:41 am

Another possibility is that the switch in the dash has dirty or slightly corroded contacts due to lack of use.
I discovered that fault after fitting a new modern pump which also failed to work.
Actuating the switch a few times brought the required result.

Cheers
John
Beware of the Illuminati


Editor: On Sunday morning, February 8th 2015, Derek "John" Pelly AKA GrumpyBodger passed away genuinely peacefully at Weston Hospicecare, Weston Super Mare. He will be missed.
User avatar
GrUmPyBoDgEr
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 3151
Joined: 29 Oct 2004
Location: Burnham-on-Mud

PostPost by: RichC » Sat Apr 16, 2011 1:49 pm

when did the electric ones come in?
mines still got the old manual pump one working fine ... certainly fun to use !
RichC
User avatar
RichC
Fourth Gear
Fourth Gear
 
Posts: 855
Joined: 28 Apr 2009
Location: Tendring Essex
Previous

Total Online:

Users browsing this forum: rjaxe, rpetersen and 10 guests