Lotus Elan

Side Light Surround

PostPost by: Over Steer » Wed Feb 14, 2007 9:45 am

I was just puting my side lights on yesterday and i noticed that they do not have a rubber surround. Should they? The fit looks a bit crude without it.
Jan

1963 23B
1969 Elan + 2
1973 Europa JPS Special
2004 Prep'ed Lotus Exige
User avatar
Over Steer
Second Gear
Second Gear
 
Posts: 104
Joined: 14 Dec 2006
Location: Malta

PostPost by: carrierdave » Wed Feb 14, 2007 10:20 am

If you men between the lens and the holder then yes there should be one.
I think they were made out of some sort of open cell sponge gasketing - mine had totally dried out and I had to cut new ones out of rubber.

Dave
carrierdave
Third Gear
Third Gear
 
Posts: 333
Joined: 23 Sep 2004
Location: Rochester, Kent

PostPost by: Over Steer » Wed Feb 14, 2007 10:23 am

no i mean between the body and the light unit, ill check for the foam later it's probably missing too
Jan

1963 23B
1969 Elan + 2
1973 Europa JPS Special
2004 Prep'ed Lotus Exige
User avatar
Over Steer
Second Gear
Second Gear
 
Posts: 104
Joined: 14 Dec 2006
Location: Malta

PostPost by: carrierdave » Wed Feb 14, 2007 11:25 pm

As far as I am aware there is no gasket between the metal lamp fitting and the body work.
Mine are screwed directly to the can with nothing between them.

Dave
carrierdave
Third Gear
Third Gear
 
Posts: 333
Joined: 23 Sep 2004
Location: Rochester, Kent

PostPost by: GHill » Wed Oct 22, 2014 8:23 pm

carrierdave wrote:I had to cut new ones out of rubber.

Dave


Hi Dave,

Mine have also dried out - can you recommend a type of rubber to be used as replacement?

Regards
Gareth
To get something you've never had, you need to do something you've never done!
GHill
Second Gear
Second Gear
 
Posts: 209
Joined: 06 Sep 2014
Location: Toronto, Canada (formerly UK)

PostPost by: jono » Thu Oct 23, 2014 12:35 pm

Gareth,

Assuming we are talking of a Plus 2, I concluded the same as you when re building mine - the side lights looked a bit wrong with a big gap around them. I purchased some O ring cord (8mm I think) and super glued to the rear flange of the lights. It fills the gap nicely and looks much more finished.

for the lense gaskets I had some self adhesive foam strip around 6mm wide which I ran around the inside of the lamp unit - the lense compresses it nicely and it provides a good seal.

Jon
jono
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1631
Joined: 17 May 2007
Location: The wet bit in the top corner of England

Total Online:

Users browsing this forum: Barney and 14 guests