Page 1 of 1

Idle speed high when warm

PostPosted: Sun Aug 21, 2005 8:50 pm
by iain.hamlton
Hi.

My carbs and timing are set up pretty well. Normally the engine idles at about 900 rpm when warm (Less if cold), but sometimes it idles at 1100-1400 after a run, gradually settling back to 900. I do not think its an air leak between the carbs (webers) and head as I have careful reseated them several times with new o-rings and tapley washers.

Anyone else seen this?
Any ideas what causes it?
Or how to fix it?

Thanks and best regards, Iain

Re: Idle speed high when warm

PostPosted: Sun Aug 21, 2005 9:57 pm
by richardcox_lotus
Likewise. I was in France earlier this year & it was v.v. hot (nearly 40C !). My car is a 72 sprint with Webers. Usually runs fine, but I did find that it was idling far too fast after a warm run. Sometimes at 2000rpm! I do have a couple of cracked thackerys, but...........

Since I've got back its been much better. My only other thoughts are:

1) Weak throttle return spring - distorting ?
2) Petrol inconsistancies.

I can't prove either of these I'm afraid, as it now seems to be running OK.

Hmmmm.

fast idling

PostPosted: Mon Aug 22, 2005 6:46 am
by iain.hamlton
Thanks for that, and I meant Thackery washers!

I was wondering about the return spring too. I have put a standard return spring, but when i got the car I had a Heath-Robinson arrangement with a long spring in tension. This pulled harder on the throttle lever, but its mounting was under a the nuts where thackery washers should have been, causing vacuum leaks.

I don't think it's petrol consistancy or quality as it run "right" or "wrong" on the same tank.

Could it be petrol foaming vapourising in the float chamber?

Or related to a malfunfunction in the brake servo? See my other post.

Best regards, Iain

Re: Idle speed high when warm

PostPosted: Mon Aug 22, 2005 10:54 am
by steveww
The viscosity of petrol changes with temp. The hotter it gets the more runny, the richer the mixture. Thus if the tickover mixture is normal to lean then the richer mixture would speed up the tickover.

Re: Idle speed high when warm

PostPosted: Mon Aug 22, 2005 11:54 am
by iain.hamlton
steveww wrote:The viscosity of petrol changes with temp. The hotter it gets the more runny, the richer the mixture. Thus if the tickover mixture is normal to lean then the richer mixture would speed up the tickover.


So is a faster tickover is normal once the carbs get warm?
I don't recall it happening with carburettor-fed cars I have had in the past. (Admittedly, they weren't very sophisticated and I probably wasn't taking much notice anyway).

best regards
Iain

Re: Idle speed high when warm

PostPosted: Mon Aug 22, 2005 7:57 pm
by steveww
Most modern carbs have compensation circuits for this. The old Weber DCOE do not.

Re: Idle speed high when warm

PostPosted: Tue Aug 23, 2005 8:17 am
by iain.hamlton
Thanks, Steve.
I am in the process of arranging an extra return spring to make sure the butterfies close consistently... But I'll tolerate a high tickover when it's warm.

best regards, iain

Re: Idle speed high when warm

PostPosted: Thu Aug 25, 2005 4:01 pm
by type26owner
You might try closing the butterflies a tiny bit more at idle. If they are open too much and are drawing fuel off the first progressive hole it'll give you the 'lazy' or racing idle.

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 7:58 am
by iain.hamlton
Thanks, Keith.
I think you are right.

The idle scew is nearly out to the point where it doesnt have any more effect, although it does touch the stop at least when cold. I removed the the brass plugs over the progressive holes, had a look down, and the butterflies put the holes on the airbox side (if you know what I mean). So it's all right when cold.

Hovever, when it's warm, and idling fast, if I push on the throttle lever by hand, the tickover revs go back down. Something is sticking.... or perhaps there is some side-to-side movement in the throttle spindle on the back carb (although I cannot feel the movement).

Last night I fitted an extra return spring, which will push as hard I do by hand to slow the revs back down. All being well, I'll try it out later, and let you know if it works.

In the process, I found the the stop under the pedal wasn't letting the throttle open all the way. Now that's fixed, I am also looking forward to a few horse power very cheap. :D

best regards, Iain

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 8:22 am
by types26/36
iain.hamlton wrote:.
if I push on the throttle lever by hand, the tickover revs go back down. Something is sticking.... or perhaps there is some side-to-side movement in the throttle spindle on the back carb (although I cannot feel the movement). Last night I fitted an extra return spring,


As well as the normal spring on the air box weber carbs have an other return spring, you have to remove the carb to get to it as it is behind the plate between the throttle shafts for each choke, it can be either an expansion spring or a coil spring.I have seen them broken and the normal spring(on air box) is not sufficient to return to idleing.
Cant remember what the internal spring arrangement for the Deloto's is but it must have one.
Brian

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 12:26 pm
by Hamish Coutts
Varying revs at idle? Too damn right I have.
Spent 2 hours fitting a new throttle cable last night. Should have taken 15 mins but I had to recut threads to make it adjust properly! Now it's fitted it is jerky and rough. :x Blipping the throttle at tickover results in an idle speed of 1,500 to 1,700 revs. Lift the accelerator a touch with your foot and all settles down to 850 revs again.
Should I persevere in the hope that it settles down or should it come back out to be relegated to living in the boot as an emergency spare. I installed this new cable as part of preventative maintenance. :x

Anybody know of someone who will supply a nice smooth, non sticking throttle cable instead of this rubbish. I know who supplied it but I don't know who made it.
Any experiences out there?

Regards,

Hamish.

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 2:03 pm
by steveww
Do not buy a throttle cable they are all [email protected] and exspensive. Go to a good cycle shop and buy a brake cable, not the cheapest you can find but one of the posh ones that are teflon lined. They run as smooth as a good pint on a hot afternoon 8)

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 4:02 pm
by Hamish Coutts
Steve,

Why the hell didn't I think of that. :shock: :oops:

Thank you!

Hamish.

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 4:05 pm
by type26owner
For the idle to race it needs more fuel AND air to do so. Steve is probably right about the fuel viscosity changing with temperature. To what degree that actually affects this stuff I really don't know for sure. The issue of the butterflies being opened too much can be explained though. On overrun the induction manifold vacuum is at it's highest. This sucks the most air past the closed butterflies. If the airflow is great enough then the first progressive hole will contribute some emulsion. This is a kind of a self-feeding situation which will slowly decay away. The trick is move the butterflies far enough away from the hole so even under the highest vacuum condition there is not enough airflow past the first hole for it to start flowing the emulsion. The emulsion required to make the engine idle should only be coming from the idle mixture screws. Much easier said than done however. :wink:

Re: Idle speed high when warm

PostPosted: Fri Aug 26, 2005 7:48 pm
by iain.hamlton
The extra return spring seems to have sorted it out. Maybe I'll replace the the internal springs when I have the carbs in bits sometime, but for now I am happy.

thanks and best regards, iain