Lotus Elan

1967 Pre AirFlow Elan S3 FHC **SOLD**

PostPost by: Truel » Sun Sep 20, 2015 7:54 am

john1180 wrote:Classy car hauler!!! Congrats


Thanks John :)
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Sun Sep 20, 2015 7:59 am

dgym wrote:It didn't fit in the wagon?


Hehe - we did have that thought but you wouldn't get the door open so decided on the trailer instead! :)

Amy's story is here if anyone's interested

http://retrorides.proboards.com/thread/ ... ect-towcar

Anyone know what colour my camcover should be, & why a PO may have cut square holes in the inner wing?

Thanks,


Matt
Attachments
IMG_20150919_140817_zps8624343a.jpg and
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: englishmaninwales » Sun Sep 20, 2015 9:07 am

IMG_1709.JPG and

I found a hammered blue on eBay (sorry I can't find a link now). Unless your car is an s/e version then it should be green.
This blue colour is close but possibly slightly too light.

Malcolm
1966 Elan S3 Coupe
1994 Caterham 7
englishmaninwales
Fourth Gear
Fourth Gear
 
Posts: 515
Joined: 26 Jul 2013
Location: Ruthin North Wales

PostPost by: gjz30075 » Sun Sep 20, 2015 9:16 am

As long as we're still somewhat in the introduction phase, tell me more about the 66 Cobra.
Greg Z
45/0243K Sprint
36/5727 pre airflow coupe
User avatar
gjz30075
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 2949
Joined: 12 Sep 2003
Location: Roswell, Georgia, USA

PostPost by: gmzez » Sun Sep 20, 2015 10:18 am

Truel wrote:...


Did the brakes bleed up ok?
Rgds Enrico

1967 S3 Elan FHC
gmzez
First Gear
First Gear
 
Posts: 24
Joined: 16 Nov 2007
Location: Oxfordshire UK

PostPost by: Truel » Sun Sep 20, 2015 1:24 pm

Thanks Malcolm - that looks just like the remnants of paint that's on there, will aim for a match for that

Gjz - Stacey is a 427, boyhood dream come true :) We bought her to race, but the jury's out on that one - the powers that be want us to run a full cage, which means cutting the scuttle, which I'm reluctant to do, so she may well simply remain a lovely way of popping to the pub on a Sunday!

Enrico - yes, all bled up fine thanks once we got some fluid moving, we'll no doubt pop a seal kit on for peace of mind but for now she's good to go for the MoT once I've sourced some tyres and got the washers washing

All the best

Matt
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: gmzez » Sun Sep 20, 2015 4:44 pm

Thanks for the update.

I have replied re washers to your email.....
Rgds Enrico

1967 S3 Elan FHC
gmzez
First Gear
First Gear
 
Posts: 24
Joined: 16 Nov 2007
Location: Oxfordshire UK

PostPost by: Truel » Sun Sep 20, 2015 9:17 pm

Thanks Enrico :) Seems an electric pump will be the way to go - will try to pick one up tomorrow

Seems the inner wing mod was commonly done to improve airflow through the engine bay, having done a bit of Googling:-

lotus-chassis-f36/paint-layers-t26995.html
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Mon Sep 21, 2015 7:54 pm

MoT all good today bar the known issues of tyres and the washer pump - should have a ticket tomorrow :-)

Cheers

Matt
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Tue Sep 22, 2015 5:01 pm

MoT'd and in use :-)

(Washer pump needs a rebuild if I can, found a suitable temporary replacement but it didn't arrive by post, so a spot of lateral thinking and the local pharmacy saved the day!)

Cheers

Matt
Attachments
IMG_20150922_172607.jpg and
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Tue Sep 22, 2015 5:02 pm

...
Attachments
IMG_20150922_172649.jpg and
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Tue Sep 22, 2015 5:03 pm

...
Attachments
IMG_20150922_174829.jpg and
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Mon Sep 28, 2015 8:29 pm

Nearly a thousand miles this week - a goodly dose of general commuting plus a run to Buckmore Park, to Rugby for a friend's Stag - all performed with sangfroid and aplomb

2 qus before I go laying into winter teardown -

1 Temp is 80/85 deg constant then 90/93 after 1hr or so on a run, but never overheats or misbehaves - normal, or am I looking for a bit of a sticking thermostat / Kenlowe switch etc.?

2 Bit of a weird, occasional, but definitely tangible rear steer issue - most parts are new but clearly some aren't or a tracking issue; any bright ideas before I tear her apart please? :)

Thanks!

Matt
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Mon Sep 28, 2015 8:40 pm

...
Attachments
IMG_20150923_231148.jpg and
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford

PostPost by: Truel » Mon Sep 28, 2015 8:42 pm

Did I mention I think she's beautiful & I love her?! :)

Cheers

Matt
Truel
First Gear
First Gear
 
Posts: 25
Joined: 12 Sep 2015
Location: Guildford
PreviousNext

Total Online:

Users browsing this forum: markymar93 and 5 guests