Lotus Elan

Fitting belts/harness for first time (ever) in a S1

PostPost by: dunclentdr » Mon May 01, 2017 6:16 pm

I have recently acquired an early S1 that retains original interior and looks like it has never had any seat belts fitted.

Now I need to make a choice between fitting some belts or some kind of harness (or both). The car does not have roll bar etc and no plans to fit.

Welcome advice and options/experience, the car will be used for fun on the road and occasionally track, although not too fast!

Thanks

David
David Rose
1963 S1 - Bourne bodied
1963 S1 - Bourne bodied
1965 S2
1966 S3
1969 Europa - 210bbhp by Banks
dunclentdr
Third Gear
Third Gear
 
Posts: 345
Joined: 06 Mar 2014
Location: United Kingdom

PostPost by: Geoffers71 » Mon May 01, 2017 9:31 pm

I fitted normal lap and diagonal belts in my S2, which hadn't had belts before. As you probably realise the single chassis bolt directly behind the seat is too far inboard to make the diagonal belt comfortable. It needs to be further out. My solution was to fabricate a strong bracket that utilises the chassis bolt and its outboard end is bolted through the wheelarch with 2 bolts and strong backing plates. Here's a pic

img_0993.jpg and


If it's not too clear I've described the process in my project thread "restoration of S2 Elan - EOK" it around page 16 though :roll:
My chassis, Spider, already had threaded provision for the inboard lap belt and the outer lap belt is similarly attached to provision in the lattice frame in the door sill. Hope that helps.
1965 Elan S2 (26/4726)
2002 Elise S2 (now sold :-()
1970 Scimitar GTE
"The older I get the better I was !"
Geoffers71
Third Gear
Third Gear
 
Posts: 412
Joined: 06 Feb 2014
Location: Plymouth, England

Total Online:

Users browsing this forum: mbell and 14 guests