Lotus Elan

Sticking throttle

PostPost by: "Jon Eckman" » Mon Oct 09, 2006 12:59 pm

Been having an intermittent problem recently with the throttle not
closing completely on my 66 S3 with webers. It's more noticeable when
the engine is warm. I adjusted the throttle cable and replaced the
return spring with the heavier duty version to no avail.

Is it possible that there are deposits on the shafts and if so, is
there an effective way of cleaning them without dismantling the carbs?

Jon Eckman
"Jon Eckman"
 

PostPost by: steveww » Mon Oct 09, 2006 2:59 pm

Check the throttle cable. Using a teflon coated bicycle brake cable
works a treat. It gives a much smoother action and is less expensive.

User avatar
steveww
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1838
Joined: 18 Sep 2003
Location: Northamptonshire, England

PostPost by: Fred Talmadge » Tue Oct 10, 2006 12:06 am

You should be able to remove the cable from the sheath and clean it a solvent.
Also using something like brake cleaner in the sheath would be good to help
clean it out. I use brake lube, but the bike cable lube idea sounds good
too.

Fred
User avatar
Fred Talmadge
Third Gear
Third Gear
 
Posts: 400
Joined: 24 Sep 2003
Location: Bellville, TX USA

PostPost by: Lincoln62 » Tue Oct 10, 2006 1:28 am

If the throttle feels and works OK with the bonnet (hood) open then I
would be looking at the cable. When you close the bonnet it pushes the
cable down making it bend to a tighter angle where it goes into the arm
on the carb which can make it sticky.

I had this problem when I got my Elan, replaced the cable with a Ford
one, still stuck, tried many combinations of springs, ended up getting a
cable from a Rover place which has worked perfectly ever since. A good,
flexible low drag cable might solve your problem.

Cheers
Peter
User avatar
Lincoln62
Third Gear
Third Gear
 
Posts: 291
Joined: 22 Dec 2003
Location: Sydney, Australia

Total Online:

Users browsing this forum: No registered users and 15 guests